Sie verwenden einen veralteten Browser und können nicht alle Funktionen dieser Webseite nutzen. Hier erfahren Sie, wie Sie Ihren Browser aktualisieren können.

OK
Karriere | Investoren

Which 32 bit and 64 bit Linux distributions does pylon for Linux support?

Until recently, pylon for Linux officially supported only OpenSuse 10.3 and Ubuntu 8.04. Packages were available that allowed these distributions to be installed without the need to also install the additional or older libraries that pylon depends on.

For distributions other than or newer than those officially supported, however, you needed to install additional libraries such as libXalan-c-110 (not for pylon-*-bininst-* packages), libXerces-c-27 (not for pylon-*-bininst-* packages), or QT 4.3.1 in order to make pylon work. But for these unsupported distributions, the installation of older libraries may "pollute" a system and cause other applications to not work correctly. In addition, once these older libraries are installed, the user must make sure that pylon is correctly linked to the libraries.

All of this made it quite difficult to use pylon on Linux distributions that were not officially supported.

To solve all of these problems, reworked pylon 2.3 packages for 32 bit and 64 bit Linux distributions have been created, and these new packages include all of the libraries that pylon depends on. The packages are called "pylon-2.3.3-1337-32.tar.gz" and "pylon-2.3.3-1337-64.tar.gz". They can be obtained from the Downloads section of the Basler website or from Basler's FTP server:

ftp://Pylon4Linux-ro:h50UZgkl@ftp.baslerweb.com

If you use either of these packages, you will not need to install any additional libraries. You must simply unpack the package according to the README and INSTALL files included in the package and at least set the environment variables appropriately, for example:

#(for 32 bit Linux)

export PYLON_ROOT=/opt/pylon

export GENICAM_ROOT_V2_1=${PYLON_ROOT}/genicam

export LD_LIBRARY_PATH=${PYLON_ROOT}/lib:

${GENICAM_ROOT_V2_1}/bin/Linux32_i86:$LD_LIBRARY_PATH

For more details, refer to the README and INSTALL files included in the package.